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Software License Agreement 

PLEASE READ THE FOLLOWING TERMS AND CONDITIONS 

BEFORE USING THIS PRODUCT. BY INSTALLING THE 

PRODUCT YOU THEREBY INDICATE YOUR ACCEPTANCE OF 

THESE TERMS AND CONDITIONS. SHOULD YOU DISAGREE 

WITH ANY OF THE TERMS OR CONDITIONS LISTED BELOW, 

PROMPTLY REMOVE ALL FILES RELATED TO THIS PRODUCT 

FROM YOUR HOST PLATFORM AND RETURN THE PRODUCT 

TO SATO CORPORATION. 

1. You explicitly agree to accept a non-exclusive license to use 

the Software identified on the distribution media solely for your 

own customary business or personal purposes. Your local 

and national laws govern this Agreement. 

2. Henceforth, “Software” shall refer to the digitally encoded, 

machine-readable data and program. The term “Software 

Product” includes the Software identified on the distribution 

media, including any accompanying documentation. The 

term “Distribution Media” refers to any method by which the 

Software Product is delivered to the end user, including but 

not limited to Floppy Disks, CD-ROM, Magnetic Tape and 

On-Line distribution via the Internet. The Software Product is 

licensed (not sold) to you, and SATO®  either owns or 

licenses from other vendors who own all copyright, trade 

secret, patent and other proprietary rights in the Software 

Product. 

3. To protect the proprietary rights of SATO Corporation, you 

agree to maintain the Software Product and other proprietary 

information concerning the Software Product in strict 

confidence and to establish reasonable procedures regulating 

access to and use of the software. 

4. You agree not to duplicate or copy the Software except that you 

may make one backup copy. You agree that any such copy 

shall contain the same proprietary notices as those appearing 

on the original. 

5. You shall not sub-license, sell, lease, or otherwise transfer all 

or any portion of the Software Product separate from the 

printer(s), without the prior written consent of SATO 

Corporation. 

6. You may not modify or prepare derivative works of the 

Software Product. You may not transmit the Software 

Product over a network, by telephone, or electronically 

using any means; or reverse engineer, decompile or 

disassemble the Software. 

7. You may transfer the Software Product with the printer(s), but 

only if the recipient agrees to accept the terms and conditions 

of this Agreement. Your license is automatically terminated if 

you transfer the Software Product and printer(s). 

8. This License remains in force until terminated, and may be 

terminated by agreement between you and SATO 

Corporation, or by SATO Corporation, if you fail to comply with 

the terms of this License if such failure is not corrected within 

thirty (30) days after notice. When this License is terminated, 

you shall either return to the place you obtained them from, or 

destroy, the printer and all copies of the Software and 

documentation. 

 

9. SATO Corporation warrants that for ninety (90) days after 

delivery, the Software will perform in accordance with 

specifications published by SATO Corporation, and that the 

distribution media will be free from defects in material and 

workmanship. SATO Corporation does not warrant that the 

Software is free from all bugs, errors and omissions. 

10. Your exclusive remedy and the sole liability of SATO 

Corporation in connection with the Software is replacement 

of defective distribution media upon their return to SATO 

Corporation.  SATO Corporation will not be liable for any loss 

or damage caused by delays in furnishing a Software Product 

or any other performance under this Agreement. 

SATO Corporation does not warrant that the functions contained in 

the Software will meet your requirements or that the operation of 

the Software will be uninterrupted or error free. 
 

11. Use, duplication or disclosure by the Government is subject 

to restrictions as set forth in the relevant guidelines of your 

country, such as the Rights in Technical Data and Computer 

Software clause at FAR 242.227- 7013, subdivision (b) (3) (ii) 

or subparagraph (c) (1) (ii), as appropriate. Further use, 

duplication or disclosure is subject to restrictions applicable to 

restricted rights software as set forth in FAR 52.227-19 (c) (2) 

or equivalent rules. 

 

THE PARTIES AGREE THAT ALL OTHER WARRANTIES, 

EXPRESS OR IMPLIED, INCLUDING WARRANTIES OF 

FITNESS FOR A PARTICULAR PURPOSE AND 

MERCHANTABILITY ARE EXCLUDED. 

SATO Corporation reserves the right to make changes and/or 

improvements in the Software without notice at any time.  

IN NO EVENT WILL SATO CORPORATION BE LIABLE FOR 

LOST PROFITS, LOST DATA, BUSINESS INTERRUPTIONS 

OR ANY OTHER DIRECT, INDIRECT, INCIDENTAL OR 

CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE 

OF OR INABILITY TO USE THIS PRODUCT, EVEN IF SATO 

CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY 

OF SUCH DAMAGES, OR ANY DAMAGES CAUSED BY 

ABUSE OR MANIPULATION OF THE SOFTWARE. SOME 

STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION 

OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL 

DAMAGES, SO THE ABOVE LIMITATION MAY NOT APPLY 

TO YOU. 

 

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS 

AGREEMENT, UNDERSTAND IT, AND AGREE TO BE BOUND 

BY ITS TERMS AND CONDITIONS. NEITHER PARTY SHALL BE 

BOUND BY ANY STATEMENT OR REPRESENTATION NOT 

CONTAINED IN THIS AGREEMENT. NO CHANGE IN THIS 

AGREEMENT IS EFFECTIVE UNLESS WRITTEN AND SIGNED 

BY PROPERLY AUTHORIZED REPRESENTATIVES OF EACH 

PARTY. BY INSTALLING THIS SOFTWARE PRODUCT, YOU 

AGREE TO ACCEPT THE TERMS AND-CONDITIONS OF THIS 

AGREEMENT. 
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Copyrights 
 

Any unauthorized reproduction of the contents of this document, in part or whole, is 
strictly prohibited. 
 
 
 

Limitation of Liability 
 

SATO Corporation and its subsidiaries in Japan, the U.S and other countries make no 
representations or warranties of any kind regarding this material, including, but not limited 
to, implied warranties of merchantability and fitness for a particular purpose. SATO 
Corporation shall not be held responsible for errors contained herein or any omissions 
from this material or for any damages, whether direct, indirect, incidental or consequential, 
in connection with the furnishing, distribution, performance or use of this material.  
 
Specifications and contents of this document are subject to change without notice. 
 
 
 

Trademarks 
 

SATO is a registered trademark of SATO Corporation and/or its subsidiaries in Japan, the U.S 
and other countries.  
AIX is a registered trademark of International Business Machines Corporation. 
Cisco is a registered trademark of Cisco Systems, Inc. 
EPSON is a registered trademark of Seiko Epson Corporation. J2SE, Java, and Solaris are 
trademarks of Sys Microsystems, Inc. 
Linux is a registered trademark of Linus Torvalds. 
Microsoft and Windows are registered trademarks of Microsoft Corporation. 
Pentium is a registered trademark of Intel Corporation. 
Unix is a registered trademark of UNIX System Laboratories, Inc. 
All other trademarks are the property of their respective owners. 
 
 
 
 
 

Software updating disclaimer 
 

While all efforts have been taken to ensure accuracy and currency of the information 
contained herein, there are instances where the contents of this document may be 
outdated. In that case, proceed to SATO worldwide websites (www.satoworldwide.com) 
to check whether an updated document has been made available for your reference. 
 
 
 
 
 
 
 
 
Version 1.1.8.0 
© 2014 SATO Corporation. All rights reserved.

http://www.satoworldwide.com/
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1. Overview 
 
 
 

The SATO All-In-One application for printer remote control was developed to achieve the 
following goals: 
 
- To simplify the SATO printer configuration and operation processes for end-users 
- To allow remote configuration and control of SATO printers that are compatible with this 

application 
- To consolidate as many of the separate software printer utilities as possible into a 

integrated application 

1.1. Supported Models of SATO Printers 
 

Currently only the following models of SATO printers are supported by the current version of 
the SATO All-In-One application: 
 
- CL4e/CL6e Series 
- CG2/CG4 Series 
- GT4e Series 
- GL4e Series 
- M-10e 
- MB2i / MB4i 
- M84SE Series 
- M84 Pro Series 
- CT4i Series 
- LM Series  
- S84 Series 
- DR308e 
- LM4 Series 
- LT408 
- D5xx Series 
- GY4 Series 
- TG3 Series 
- TH2 Series 
- GZ4 Series 
- CL4NX Series 
- S84ex/S86 ex 
 
The SATO All-In-One application will be undergoing continual refinement, and it is expected 
that other SATO printer models will be supported in future, in line with customer demand.  
 
 
 

 
 

 
 
 
 
 

   1 
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2. System 
Requirements 

 
The minimum system requirements for the SATO All-In-One Application are  
 

 A computer with at least a 450MHz Pentium
®
 CPU with 128 MB of RAM, running 

Windows 2000, Windows XP, Windows Server 2003, Windows Vista, Windows Server 
2008 or Windows 7 platforms. 

 Installed .NET Framework 2.0 (or higher version) 

 At least one supported model of SATO printer that can connect to the computer 
running this application  

 
 
Standard SBPL commands are sent to SATO printers to update configuration settings or to 
retrieve data. The data will then be presented in a meaningful and graphical interface for the 
software user. 
 

 
 

Figure 1  System Overview 

 
Currently, SATO All-In-One Application does not require a database system. The only 
scenario where persistent data is needed is during the exporting of application profile into 
XML files. 
Please Note that Windows Vista and above OS user must be administrator in order All-In-
One tool to perform well. Things like saving Preference Settings, Firmware download etc 
might not function well if user does not have admin rights. 
 
 
 
 

All-In-One 

Application 
User 

- Communicate with 
printers using 
TCP/IP, USB, LPT 
or RS232 with SBPL 

 
- Handle all different 

commands and 
operational 
parameters among 
the various printer 
models 

 
- Present control 

information in a 
friendly graphical 
user interface  

 

- The complexities 
of configuration 
and SBPL 
commands are 
hidden from users 

 
- User will see a 

unified approach 
to configure and 
administrate 
various models of 
SATO printers. 

 
 

   2 
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3. Setup 
 
 
 
After obtaining the installation software, double click on the setup file to install the application. 

 

 

Figure 2 Setup screen 

   3 
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Figure 3 License Agreement 

 In order to have access to the “Next” button to proceed with the installation, the user must 
agree with the License Agreement by clicking on the “I Agree” radio button.  
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Figure 4 Installation folder 

 

 

Figure 5 Confirmation 

 Click the “Next” button to start the installation. 
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Figure 6 Installation in progress 

 

 

Figure 7 Installation Complete 

 
The program can then be launched from the Start Button->All Programs->SATO->SATO All-
In-One Application program group. 
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4. Using the All-In-
One Application 
4.1. Overview 
 

 The SATO All-In-One Application works on the following paradigm: 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

   4 

CONNECT 

Link to supported 
printer(s) via Auto-
Discovery or via 
manual entry  

IEEE1284/ 

RS-232C 

LAN/ WLAN 

USB 

1 
ORGANIZE 

Use the graphical treeview  
structure to organize connected 
printers into groups using 
custom folders & display names. 

2 
CONTROL 

Configure/control 
any SATO printer 
regardless of its 
location in the world. 

3 
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4.2. Summarized Features List 
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1 Auto-Discovery O O O O O X O O O O O O O O O O O O O O 

2 Saving and loading Printer 
Configuration 

O O O O O O O O O O O O O X O O O O O O 

3 Displaying and setting of 
Printer Configuration 

O O O O O O O O O O O O O X O O O O O O 

4 Firmware Download O O O O O O O O O O O O O O O O O O O O 

5 Concurrent download 
firmware to multiple printers 

O O O O O X O O O O O O O O O O O O O O 

6 Send and query SBPL 
command 

O O O O O O O O O O O O O X O O O O O O 

7 True Type Font Download 
(Expanded 
Memory/Cartridge) 

O X O O X X X X O X X X X X O O X X O O 

8 Graphics Download O O O O O X O O O O O O O O O O O O O O 

 Supported Interface                     

9 LAN O O O O O O O O O O O O O O O O O O O O 

10 RS232c  O O O O O O O O O O O O O O O O O O O O 

11 IEEE1284 Parallel Port  O O O O O X O O O O O O O O O O O O O O 

12 USB O O O O O O O O O O O O O O O O O O O O 

13 Test Print  O O O O O O O O O O O O O X O O O O O O 

14 LAN Interface Card 
Configuration 

O O O O O X O O O O O O O X X O O O O O 

15  Format Download to Keypad X X X X X X X X X O O X X X X X X X X X 

16 Bitmap Font Download 
(Internal Memory) 

O O O X O O O O O O O O O X O O O X X O 

17 TH2 Package Download X X X X X X X X X X X X X O X X X X X X 

 
Note:  For troubleshooting purposes, SATO All-In-One Application generates a log file to 

capture important debugging information such as error codes. By default, the log file is 
created at c:\ directory and the file name is SATO_All-in-one.log.  
The default directory can be changed from the dialog box in Option->Preferences. Refer 
to Section 4.24 Application Configuration for details.  
When reporting bugs or problems, copy the log file to the systems support team.  
The default directory can be changed from the dialog box in Option->Preferences. Refer 
to Section 4.24 Application Configuration for details.  
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4.3. Multi-Lingual Support 

 

Figure 8 Multi-Lingua Support 

 
 This version of All-In-One tool supports English and Traditional/Simplified Chinese. 

User can change the language setting at the Options->Preferences.  

4.4. Adding a Printer 
Only SATO printers, specifically those supported by this All-In-One application, can be 
detected and added. Currently, the following interfaces are supported: 
  

 LAN (Wired and Wireless, TCP/IP) 

 Serial Communication (RS232c) 

 Parallel Port (IEEE 1284) 

 USB (Plug & Play) 
 

 
For printers using SILEX Network Interface card (such as GT and CL), it is 
necessary to use the SILEX firmware which supports bi-directional communications 
on port 9100, i.e., version A1.2.3 and above. 
* For SAI-SILEX firmware, it is necessary to add the printer with Port no.: 1024. 

 
The All-In-One Application provides three methods for detecting and/or adding 
compatible printers to the system: 
 

1. Using the Auto-Discovery mode 
2. Manually entering an IP Address, or Parallel Port/Serial Comm settings 
3. Specifying a range of IP Addresses 
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In any of the above modes, the system will attempt to handshake with the target 
printer(s) and issue an appropriate command to retrieve the printer firmware 
information. If the handshake is successful, the detected printer(s) will be presented in 
the main panel’s treeview as an icon. 
 
Note: When All-In-One Application tries to connect to the printer, it is important to 
ensure that there is no other application (such as printer driver) using the printer at the 
same time. 
 
For example, a printer driver which is actively connecting to the CT412i via the USB port 
with printer driver will cause connection problems to All-In-One Application with this 
printer. 
 

 

Figure 9 Active connection from printer driver 

 

4.4.1. Adding a Printer via Auto-Discovery 

The All-In-One Application can automatically detect SATO printers connected via USB 
interface, the SILEX network interface card (CL and GT series), or the standard built-in 
LAN interface (new CT4xxi series, CG Series), or the GL Series Network Interface card. 
 
Upon installation, the software automatically registers itself into the Windows Firewall 
Exception list. Thus, the firewall can continue to protect the computer without 
compromising the functionality of the Auto-Discovery feature. 
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Figure 10 Exception entry in FireWall 

 

4.4.2. Adding a Printer via LAN, Parallel Port or Serial Comm settings 

You can add a new printer to the system by specifying its IP Address, USB port, Parallel 
Port or Serial Comm settings such as network port, communication port and baud rate. 
User with USB to Serial can easily notify with USB2Serial text beside com port. USB to 
Parallel port is now supported and will listed under USB Port. 

  

Figure 11 Add New Printer 

 Note: GL printer with Standard Protocol is able to be added with this method. However, 
it might take a little longer.  
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4.4.3. Add a Printer by specifying an IP Range  

SATO printers such as MB200i/400i which do not use the SILEX Network Interface card 
can be auto-detected if you use the “Add Printer – By IP Range” feature. 
 
 

 

Figure 12 Add Printer - By IP Range 

 It takes the application approximately one second to probe each IP address in the IP 
range to determine whether it is a SATO printer (by checking the vendor code in the MAC 
address). Thus, if you specify a wide IP range, the application may take an unacceptably 
long time to complete the task. Therefore, a “Cancel” button is provided to allow you to 
cancel the operation. 

4.5. Navigating the Treeview 
After all target SATO printers have been successfully detected or registered into the 
application, they will appear in a Tree view as icons (See Figure 12 below) representing a 
Node. You can manage the nodes in this view (hereafter called the treeview) in various 
ways, as follows. 

 

 
Figure 13 Treeview 
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4.5.1. Creating folders 

By default, detected printers will populate the treeview as nodes at the root. However, 
just as with any standard treeview in Windows Explorer, you can also create your own 
folders in the root, and then drag-and-drop any registered printer to and from any folder 
or root area. 
 
By creating folders, you can organize connected printers into groups meeting particular 
criteria such as “all GL printers on the Production Floor” or “All compact printers in the 
Packaging Dept” . You can then control printers in that group more conveniently rather 
than individually select different printers when needed. 
 
The only limitation is that your custom folders must contain a non-blank name, and the 
folder name cannot be “root” or “main”. Also, within the same level, the same folder 
name cannot be repeated.  
 
 

4.5.2. Renaming folders 

The folder name and the “display” of the printer can be renamed on the treeview. Click 
on the folder name and wait for the text editing cursor to appear, then type the new 
name. 

 

4.5.3. Relocating printers via Drag-and-Drop  

A node icon can be moved in and out of the root area or folders easily. Just make sure 
the source and target locations are visible, then drag the icon and drop it in the target 
location.  

4.6. Displaying Printer Firmware Information 
When a printer node on the treeview is clicked, you will see basic information about the 
printer, as depicted below. 
 

 

Figure 14 Printer Information 
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4.7. Editing Printer Information 
 You are allowed to change the printer’s Display Name and the Model, which are 
displayed next to the node icon. 

 

 

Figure 15 Edit Printer Information 

Changing the Display Name/Model does not affect the printer. No command will actually be 

sent to the printer. The changes apply only to the treeview of the SATO All-In-One 

application, and are stored in memory or exported to XML files when you export profiles 

(See Section 4.11 Export/Import Profile).  

4.8. Enquiring Printer Status   
For printers connected by LAN, the SATO All-In-One application periodically sends a 
status-probing command and display the printer status for monitoring purposes.  
 
This feature is not available to printers connected via Parallel Port and RS-232. This is 
based on the assumption that local printers (non LAN) can be monitored locally rather 
than via remote. 

 

 

Figure 16 Status Monitoring 
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4.9. Interface Configuration 
Interface Configuration feature is available for CT, MB, CG printers and e-series models 
that connected with LAN interface.  
 

 

 Figure 17 Interface Configuration 

 
 
Note: When the “Interface Configuration” window is open, the ENQ Status monitoring 
function of the printer will be stopped. 
 
The following picture shows the Interface Configuration for MB printer: 
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 Figure 18 MB-series Interface Configuration 

      This function supports concurrent setting to multiple MB printers. The following interface 
settings can be configured on this functionality: 
 

- RS232 settings 
- IrDA settings 
- Bluetooth settings 
- Wireless LAN settings 

4.10. Displaying Configuration Information 
The displaying and updating of printer configuration information is split into 2 parts: 
Printer information and Label information. These can be viewed and updated by clicking 
the “Printer Configuration” and the “Label Configuration” button respectively. 
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4.10.1. Printer Configuration 

SBPL commands will be sent to the printer to retrieve the printer configuration        
information. The screen will only display the system configuration Information such as   
print speed and darkness level. 

 

 

Figure 19 Printer System Configuration Information 

 Use the drop-down lists to make any necessary changes to the configuration. When the 
“Submit” button is pressed, the system captures your inputs and issues SBPL commands to 
change the settings in the printer. 
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4.10.2. Label Configuration 

The remaining configuration data contains label configuration information. The unit of 
measurement will be changed from “dot” to “mm”.  

 

 

Figure 20 Label Configuration 

Use the drop-down lists to make any necessary changes to the configuration. When the 
“Submit” button is pressed, the system captures your inputs and issues SBPL commands 
to change the settings in the printer. 
 

4.10.3. Print Head Information Display 

Some supported model can click on ‘Print Head Information’ button under Configuration to 
view the detail information for print head counters and statuses.  

 
Figure 21 Print Head Information Display 
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4.11. Export/Import Profile 
The effort and time required to populate the application’s treeview with the correct 
printers and folders, need not be repeated every time you start the All-In-One 
application. By saving the “profile” of already detected printers into a file (in XML format), 
the application will not normally need to auto-detect printers on the network again, unless 
you force the software to do so. 
 
The profile can also be exported to other computers connected to the same printers, so 
that the same treeview information can be restored without delay. 
 
The following information is captured in the XML profile file: 
 

- Folder Information 
-   Name 
-   Tree Level 
- Printer type 
- Name 
- Model 
- DisplayName 
- Firmware Version 
- Folder Name 
- Interface Type 
- IP Address 
- Mac Address 
- Port 
- Baud rate 
- Parity 
- DataBits 
- StopBit 
- HandShake 
- PortName 

 
 

Click File->Export Profile or File->Import Profile to download or upload the printer 
configuration profiles. 

 
 

4.11.1.  Using External Profile 

 

Figure 22 Open External Profile 
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By default, All-In-One loads printer profile information stored in the application directory during 
start-up. However, user can choose to load the printer profile information stored in other 
directory. 
User chooses an external printer profile by File->Open External Profile. The application title 
shows the name of the external profile, to indicate that the current printer profile used by the 
application. 
 

 

Figure 23 Using External Profile 

 

 

Figure 24 Closing and Switching Profile 

Close External Profile: This is to close the external profile and loads again the internal 
application profile. The internal profile will be loaded during the next application start-up. 
 
Switch to Local Profile: This is to switch to the local application profile but the external profile is 
still open. The external profile will be loaded during the next application start-up. 
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4.12. Graphics Conversion 
This utility provides conversion functions from raster graphics files 
(*.BMP;*.GIF;*.JPG;*.PNG) into SBPL commands. Click Tools->Graphic Conversion. 

 

Figure 25 Graphics Conversion 

 
Click the Open button to browse for the desired graphics file. A preview of the file will be 
displayed. You can also edit the graphic by using the Stretch or Center button, or reset the 
changes using the Normal button.  
 
The appropriate SBPL commands for printing the file will be displayed in the bottom-most 
window. Click Save to save the commands into a file, or click Close to end the conversion. 

4.13. Loading Graphics  
Click Tools->Graphics Download. This function allows you to upload and store the 
graphics into the memory of a printer. It supports the following graphics formats: 

- BMP 
- JPG 
- GIF 
- PNG 

 
The function supports the following types of uploading formats: 
1) SATO Graphics (ESC+GR/GI command) 
2) Bitmap Images (ESC+GT/GC command) 
3) PCX Images (ESC+PI/PY command) 
4) Logo in Internal Flash (FD command) 
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Figure 26 Graphics loading 
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4.13.1. Dithering Effect 

For Bitmap and PCX files, the Dithering effect feature is available to allow downloading 
of graphics with color fading effects. 

 

Figure 27 Dithering Effect 

 
 



 

 
SATO All-In-One Application                                                                                                                                     29-60 
User Manual 
 

4.14. Font Downloading 
Click Tools->Font Download.  
 

 

Figure 28 Font Download 

 
Full set of True Type Font (TTF) can be downloaded to the extended memory or cartridge. 
Whereas only selected size font (bitmap font) can be downloaded to internal flash. The 
following shows the steps of downloading full set of TTF into extended memory or 
cartridge. 
 
The Font information can be reused and applied onto another printer by using the “Load 
List” and the “Save List” functions.  
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4.14.1. Font Selection 

 

Figure 29 Font Selection 

When the “Add Font” option is selected from the popup-menu (5), the above dialog box will be 
displayed to let you select the font to load. 
 

- Without specifying international character set 
This option is for User TrueType Font load. The command will have a prefix  
ESC+RD<x>00, where x ranges from ‘u’ to ‘z’, to be specified by user. 

- Standard international character set 
This option is for Code Page 850 character set. The command will have a prefix of 
ESC+RD<x>10, where x is specified by user according to the font style: 
 

F FuturaIIBook 

G CG Triumvirate Condensed 

P CG Palacio 

S CG Century Schoolbook 

V Univers Medium 

u,v,w,x,y,z User True Type Font 
 

- Extension international character set 
This option is for a font that contains an extension international character set such as 
Arabic and Thai. The command will have a prefix of ESC+RD<x>20, where x is 
specified by user according to the font style: 
 

V Univers Medium 

t CG Times 

T Angsana UPC 

u,v,w,x,y,z User True Type Font 
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- Extension international character set 
This option is for double-byte character sets such as Chinese, Korean and Japanese. 
The command will prefix with ESC+RD<x>00, where x is specified by user according to 
the font style: 
 

C Simplified Chinese (GB2312) 

C Traditional Chinese (Big5) 

K Korean (HYGungSo-Bold) 

u,v,w,x,y,z User True Type Font 
 

4.15. Bitmap Font (fixed size) Download  
Bitmap font with specific size can be downloaded into the Internal Flash of the printer using FD 
command. The font downloaded with this method can be recalled using the ESC+RF command. 
Refer to the command specifications of each model for details. 

 

Figure 30 Selecting Internal Flash for Bitmap Font Download 
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The Refresh button is to get updated storage information of the Internal Flash. Note that the 
storage space is used for both Bitmap Font and Graphics downloaded using ESC+FD 
command. 

 

Figure 31 Download Fixed Size Bitmap font 

Multiple range of character set is possible by selecting the character while holding down the 
[Ctrl] key. It is able to span across different Character Set. 

4.16. Firmware Download 
 

4.16.1. MB200i and MB400i 

Select any MB200i and MB400i printer from the treeview, right click on it and choose 
Firmware Download from the popup menu. The firmware must be loaded using RS232c 
interface. 
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Figure 32 MB Firmware download 

 
 

4.16.2. CL, CG, CT, LM, S84 and GT 

 

 

Figure 33 Boot or Flash Download 

 
User is to select the download mode: Boot or Flash Download. 
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4.16.2.1. Boot Download mode 

 

 

Figure 34 Boot Download mode 
 

User is advised to take extra precautions when using this function. Instruction on the dialog 
must be strictly followed. This process is carried out with a mixture of human interventions of the 
printer and the application. 
 
When the first firmware file is completed, user is to set the printer (by pressing button on the 
printer) to ensure it is on “Program Download” mode before the next file is sent from the 
application. Failure in doing so might cause unexpected exceptions and damages to the printer. 
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Figure 35 Executing next firmware file 
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Figure 36 Download Complete 

 
When the downloading processing is complete, user is to perform a default setting on the 
printer, manually. 
 
Please note that the downloading process must be complete without interruptions of the 
connectivity to the printer.  
 
 
* Important: for downloading of emulation firmware, it is important to refer to the respective 
firmware download manual for the correct procedure. Certain types of firmware require 
downloading of font file in order to get the firmware upgrade process working. The sequence of 
files to download also has to be strictly followed. 
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4.16.2.2. Flash Download Mode 

 
This function supports firmware loading of GT/CG/CL/CT/LM/S84 with the following 

limitation: 
- Older CL firmware that does not provide the Auto Download and the Restart 

command will not be supported 
 
The download process is automatic, where the All-In-One tool automatically sends the next 
firmware file and restarts the printer to perform factory clear + default setting after download 
completes. 
 
It supports concurrent firmware loading to multiple printers (of the same model). 
 

 

Figure 37 Firmware Download for CL and GT  
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4.16.3. GL 

This function currently supports firmware loading via a LAN interface. The FTP protocol is 
used to transfer the firmware file from host to printer. 
 
The printer will automatically restart after the firmware loading is complete. 
 

 

Figure 38 GL Firmware loading 

 

4.16.4. TH2 Downloader 

User can use TH Downloader Feature to 
download package (.pkg) file to multiple TH2 
printers concurrently. Select Tools->TH 
Downloader menu to open TH2 Downloader 
dialog. Select .pkg file to download, select the 
printers to download and proceed with “Start 
Download” button. 
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Figure 39 TH2 Downloader 

 

4.17. Test Print feature 
 

 

Figure 40 Test Print 

 
This feature allows user to send built-in Test Print commands to any registered printer. 
The user can invoke the standard test print functions such as User Test Print or Factory 
Test Print, in either small or large label sizes. 
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4.18. Switching Interface Selection for CG Printer 
After the CG printer is added to the application, the interface selection can be switched by 
right-click the printer to bring up the Context Menu, and choose the “Interface Mode”.  

 

 

Figure 41 Switching Interface Selection for CG Printer 

 
 Note: User is required to manually restart the printer after switching the printer 

interface mode.  
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4.19. Restart Printer 
Currently, this function is only available on CG and GT models. 

 

Figure 42 Restart Printer 

For CG printer, if the printer is on LAN interface, it will be switched to USB mode after 
restarting the printer with Factory Default. 

 
 Note: Do not use this function if the printer has just changed the interface mode. 
 

 

Figure 43 Restart Printer Function will not work if the Interface Mode has changed 
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4.20. RFID Mode Setup (for CG2 and CT4i) 
Currently, this function is only available on CG2 and CT4i printer. 
 

 

Figure 44 RFID Mode Setup 

 
This function allows user to switch between normal mode, RFID mode and enhanced RFID 
mode. It is only applicable to printer with the optional RFID kit installed. 
 

 

Figure 45 RFID Mode Setup Dialog 
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4.21. Sending Printer Command Strings 
Right-click a printer icon from the treeview and choose Send SBPL Command from the 
popup menu. This function allows the user to send SBPL commands in both text format and 
file format. The user can also use it to retrieve printer response from the command. 
 
The response of the printer is displayed in both ASCII and HEX formats. 

 

 
Figure 46 The Send Printer command 

 
 

4.22. Saving and Applying Printer Profiles 
 

 

Figure 47 Saving and Applying a Printer Configuration 
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This feature is necessary for users 

who need to apply a set of tested 

settings to many printers at once. 

 

For Saving Printer Configuration, an  

SBPL command will be executed to 

retrieve the Printer Configuration of 

the selected printer. The information is 

then saved into an XML file specified 

by the user. 

 

For Applying Printer Configuration, the 

command will be executed after 

reading the XML file which is specified 

by the user. 

  

An example of the XML file is shown 

here (Figure 30). 

 

 

 

Figure 48 XML File 
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4.23. Mass Update of Printer Configuration 
This feature is to apply a printer configuration to more than one printer (within the same 
model) concurrently. Click Tools->Mass Apply Configuration. 
 

 

Figure 49 Mass Update of Printer Configuration 

 
 After selecting the printer model, the user can choose the printer configuration file (that 

was previously saved as explained in section 4.22). A list of printers of the selected 
models will be displayed. User can hold the Control Key to perform the multiple 
selections of the printer to apply the configuration. 
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4.24. Application Configuration 
Some aspects of the application can be configured at Options->Preferences 

 

 

Figure 50 Preferences Dialog 

This should be the only proper way to change the application configuration information. 
Configuration files should not be modified without advice from SATO technical staff. 
In case of application problem user should check “Enable Debug Logging of Application” feature 
and run the application to recreate issue and provide SATO_All-in-One.log file to customer 
support for help. 

4.25. AutoDiscovery Setup  
To refine the AutoDiscovery feature use the setup dialog available from Options->Auto-Discover 
Setup menu. This is option is meant for advance user who has good knowledge with networking 
on PC. This dialog allows changing the default interface to send discovery packages. Multiple 
broadcast address could be added to suite the various customer needs. 
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Figure 51 AutoDiscovery Setup Dialog 

4.26. Configuration of Network Interface Card 
For SATO Printers equipped with Network Interface Card, the network properties (such as IP 
address and Wireless settings) can be configured by choosing the “Interface Configuration” 
function. 

 

Figure 52 Configuration of Network Interface Card 
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4.27. Check for Newer Version of Application 
 
The application offers a feature to help user to check if a newer version of the application is 
available on the website. 
 

 

Figure 53 Check for Update 

 
If there is a newer version, the following dialog will be displayed. 
 

  

Figure 54 Found newer version 

 
If the user clicks the “Yes” button, an Internet Browser will be opened to download the latest the 
application package. 
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4.28. Changing Communication Protocol of GL4 
The communication protocol of GL4 printer can be configured by right-clicking on the GL printer 
node, and then choose “Communication Protocol”. 

 

Figure 55 Changing Communication Protocol of GL4 

The printer is not required to be restarted after this operation. 
This function is only applicable for GL4 printer with LAN/WLAN interface mode. 
 

4.29. Send SBPL Print File to Printer Driver 

This function allows sending of SBPL print file to SATO printer driver. The print 
file will be sent to the print through the interface defined in the driver properties-
>Port Setting. 

Note that the driver settings such as Print Speed or Print Darkness will not be 
applicable to the print file. 

Click Tools->Send SBPL to Printer Driver 



 

 
SATO All-In-One Application                                                                                                                                     50-60 
User Manual 
 

 

Figure 56 Send SBPL to Printer Driver 

 

Only SATO printer drivers installed in the PC will be displayed.  
 
If the print file is to be printed more than once, and delay is needed in between 
the print files, then check the Interval checkbox and input the time delay value 
(in millisecond, 1 second = 1000 millisecond). 
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4.30. IP Assignment 
This function allows user to perform quick search of all Sato printers connected to 
network. Some network configurations such IP and SubnetMask settings are possible. 
 
Click file menu->Tools->IP Assignment Tool 

 

Figure 57 IP Assignment Tool 

 

 

Figure 58 Network Setting 
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4.31. Unit Convertor 

This function allows user to perform unit conversion among dots, mm, 
cm, inch and hex, in the corresponding resolution. 

Click file menu->Tools->Unit Conversion 

 

Figure 59 Unit Convertor 
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4.32. Status Alert via Email 
This function sends alert emails to the specified users if an error occurs on the 
monitored LAN/WLAN printers. Click file menu->Tools->Status Alert 
By default Popup is enabled to disabled check the Disable Popup top right 
corner of Alert Configuration dialog box. Alert popup will appear top right corner 
of Display Screen. 
 

 

Figure 60 Email Alert Notification 

 
Note : User is to specify the address of out-going email server (SMTP Server). 
Depending on the email configuration, user might need to provide information of 
an authenticated email account under the “Mail Server Authentication” in order 
to make use of the server to send emails. 
 
 
 
 
 
 
 
 
 

Figure 61 Alert Popup Dialog 
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Figure 62 Log File 

Detected errors can be logged in a log file by enabling the Log File option and 
provide a log filename. 
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4.33. Real Time Clock (RTC) Setting 
This function is to send the RTC configuration command to the printer. It is only applicable on 
those printers with RTC module installed. 

 

Figure 63 RTC Configuration 

 
By default, the current date/time from the host system is displayed as the setting. Upon 
changing the value of the drop-down list, the value of the date/time is changed accordingly. 

 
Figure 64 RTC Date/Time Setting 

 
Click the “Refresh” button to get the updated date/time information from the host PC. 
Click the “Submit” button to send the RTC Setting command to the printer. 
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4.34. Format Download to Keypad 
This function is to send the Format files to the keypad via the printer. It is only applicable to 
those printer models which support Keypad and download can be done only when keypad is 
attached to printer. Format Files are created with SATO Keypad Tool software. In Format 
Download Dialog click Open button and select SD Card folder \Data\FMT\FMT_xx\*.dat file to 
download to printer.  
 

 

Figure 65 Format Download to Keypad 

 

4.35. Status Bar Icon, System Tray 
All-In-One tool provide Status Bar icon so that if needed user could run All-In-One tool in 
background and minimize to System Tray. If Close to Tray setting is selected, Application will 
minimize to System Tray when user try to Close the windows without using File->Exit menu. 
Exit menu will actually exit the application from System Tray as well. 
 

 

Figure 66 Status Bar Icon and menu 
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4.36. Shortcut Menu to SATO External Tools  
All-In-One tool provided shortcut menu for all tool installed under “SATO” Start Menu Program 
folder. This provides quick and easy access to other SATO software user might need directly 
from All-In-One tool. 
 

 

Figure 67 Other Sato Applications in Start Menu 

 
 

Figure 68 Shortcut Menu to SATO External Tool via All In one 
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4.37. Non-Standard Protocol   
All-In-One use Standard Protocol for sending or querying data to printer. In Standard Protocol 
mode, commands are started with ESC (Hex 0x1B). SATO printer can be operated in Non-
Standard mode where escape character where printable characters (eg. ^ character is used 
instead of ESC for command). 
 
User can identify the current protocol by looking at the main treeview, before the printer name. 
By default printer were added as Standard protocol and user has to manually change to correct 
protocol mode by using context menu of printer in treeview. 
 
User can change the Non-Standard code while switching to Non-Standard protocol. 

 

Figure 69 Standard and Non-Standard protocol 

 

4.38. Software DIP Switch Setting 
 
Some printer models such as GZ 
Series support setting DIP Switch 
setting via Software, SBPL command. 
This feature provides easy way to 
setup DIP Switch setting via AIO Tool. 
Please note that at present, reading of 
current DIP Switch setting is not 
supported. That means the setting 
displayed upon loading of dialog is just 
the default setting which may not be 
the same as the current setting of 
target printer. 
Right click on printer name and select 
DIP Switch Setting from context menu 
to invoke DIP Switch Panel dialog. 
 

Figure 70 DIP Switch Setting Context Menu 
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Use Mouse to click on DIP Switch as desired and click Set button to send SBPL command to 
printer. User could choose the command protocol to use either SBPL or SZPL using radio at the 
bottom of dialog. Preset commands listed some other useful preset command to sent to printer. 
Please note that last two Reboot command can only be sent when the printer is in Download 
Mode. The command will be ignored in Online mode. (Note: At present, only GZ printer support 
this feature.) 
 

 

 

Figure 71 DIP Switch Panel 



   
 

 

 

 

 

 

Extensive contact information of worldwide SATO 
operations can be found on the internet at 

www.satoworldwide.com 


